Reliability and Vulnerability Scanning for Plesk

Keep your server configuration up-to-date with automatic fixes of vulnerabilities

Imunify QuickPatch provides reliability and configuration recommendations and automatic fixes for servers running the Plesk control panel. Based on the analysis of real-world operational data collected from systems worldwide, it helps you keep your servers vulnerability-free.

Get insights on server configurations and fixes to help avoid vulnerabilities

Works on Ubuntu, Debian, CentOS, and RedHat Linux distros

For Plesk

Free and Premium editions can both be used for evaluation and production

Imunify quickpatch features

FREE

Analyzes your server configuration and reports security vulnerabilities in packages distributed by the OS vendor;

Reports whether or not the OS vendor has released an update which fixes a vulnerability, with links to its descriptions and details.

Just $6 per server/mo

Analyzes your server configuration and allows you to select and fix vulnerabilities from within the UI;

Allows you to configure the automatic daily fix of all vulnerabilities, or only critical ones;

Provides email and dashboard notifications for automatically fixed vulnerabilities and newly discovered critical vulnerabilities.

Visit the Plesk Extension catalog to download for free or to buy the Premium version for just $6 per server/per month.

Frequently Asked Questions

What is QuickPatch?

Vulnerability scanner for Plesk that provides reliability, configuration recommendations and automatic fixes for servers running Plesk control panel.

How do I get started with QuickPatch on Plesk?

Visit the Plesk Extension catalog to download QuickPatch for free.

What is the price of QuickPatch?

QuickPatch is available for free.

GOT ANY QUESTIONS ABOUT IMUNIFY SECURITY?

Our top-notch support is here to help.

24/7/365

Vulnerabilities check is powered by: